Videocenter with mplayer

Posted on September 8, 2007
Filed Under Maemo, N800, Software, Tips |

This is the application I’ve been waiting for. But it has abug (or a feature) that needs some knowledge to bypass.

So the idea of this program is to be able to watch vidcasts & live TV easily on the go. A feature that I almost decided to implement myself :) But because this program uses the internal mediaplayer for videos, it doesn’t support all the shows I want.

Luckily there’s a option in the settings to use external player.

screenshot00.png

To use mplayer for example, just enter this path to the box:

/usr/sbin/mplayer -cache 1024 %s

The “cache” is optional but it’ll make mplayer stream those videos much more smoothly.

The tricky part is to use that external player. If you just press the “>>”-button, the video will start in the internal player even though external is selected. To launch the stream in mplayer you’ll have to go to internet videos screen, select the video and go to “menu->file->stream video”. That’s all there’s to it.

screenshot02.png

Thanks again for the great application.

Comments

5 Responses to “Videocenter with mplayer”

  1. sam gonzales on September 18th, 2007 16:34

    are those spaces in the path? or is it all togehter?
    “/usr/sbin/mplayer -cache 1024 %s”

    I’ve entered it both ways and nothing happens..

  2. Bobo on September 18th, 2007 16:38

    There are spaces between -cache, 1024 etc. But do you have Mplayer installed? You can get it from https://garage.maemo.org/projects/mplayer/ or more easily http://maemo.org/downloads/product/mplayer

    If you still don’t have any luck, try to install xterminal and use the terminal command ” find / -name ‘mplayer’ ” to locate the binary.

  3. well now on September 30th, 2007 06:44

    the path is different for me. if you open up a terminal and type ‘which mplayer’ it will tell you where your mplayer binary is located.

    Mine was at ‘/usr/bin/mplayer’ and not /usr/sbin/mplayer

  4. well now on September 30th, 2007 11:17

    …which isn’t to say it was in any way functional on a 770 running OS2007HE.

    After enough 2 minute pauses where the UI locked up and various complete crashes and videos that refused to play in either mplayer or Media Player I just dumped the whole deal.

  5. bun on October 1st, 2007 04:26

    Thanks, Langaton.org. The mplayer tips are good. Videocenter is up and alive and working beautifully on 770, http://www.internettablettalk.com/forums/showthread.php?p=78544#post78544.

    bun
    ____________________________
    2007He2007.36-2 flash/MMC 2G

Leave a Reply




*
To prove you're a person (not a spam script), type the security word shown in the picture. Click on the picture to hear an audio file of the word.
Click to hear an audio file of the anti-spam word